Skip to content

deps: move versions.lock past new advisories (certifi, filelock, virtualenv) - #13

Merged
Harshith029 merged 1 commit into
mainfrom
deps-audit-2026-10
Oct 24, 2026
Merged

Harshith029 merged 1 commit into
mainfrom
deps-audit-2026-10

Conversation

@Harshith029

Copy link
Copy Markdown
Owner

What and why

CI's pip-audit started failing every PR (#11 and #12 included) on advisories published this week against versions.lock. Merge this first; the other open PRs' audit job passes once it is on main.

Package From To Why
certifi 2026.5.20 2026.10.19 PYSEC-2026-4320. Ships in the container image (installed from the lock)
filelock 3.29.0 4.2.1 3 CVEs, no 3.x fix. Only used by pre-commit tooling (virtualenv, python-discovery), which accept 4.x
virtualenv 21.7.13 21.14.10 11 CVEs; 21.14.9 still had CVE-2026-113713, fixed in 21.14.10
packaging 26.2 26.3 required by virtualenv 21.14.x (>=26.3)
distlib 0.4.0 0.4.3 required by virtualenv 21.14.x (>=0.4.3)

Smallest fixed or required versions, per CONTRIBUTING. filelock 4.2.1 needs Python 3.11, SENTINEL's floor. Requirements were checked on PyPI before bumping.

Testing

  • pip-audit==2.10.1, run exactly as CI runs it (-r versions.lock --no-deps --disable-pip, same ignore): no known vulnerabilities.
  • scripts/check_versions_lock.py: 0 conflicts. pip check: no broken requirements.
  • Full suite on the new pins: 688 passed, 12 skipped, 1 expected xfail. ruff and mypy --strict clean. The pre-commit hooks (gitleaks) ran on the commit with the new virtualenv.

Security invariants

  • No code changes; dependency pins and the changelog only.

🤖 Generated with Claude Code

…ualenv)

CI's pip-audit started failing every PR on advisories published this
week against three pins:

- certifi 2026.5.20 -> 2026.10.19 (PYSEC-2026-4320). This one ships:
  the container image installs from versions.lock.
- filelock 3.29.0 -> 4.2.1 (three CVEs; no 3.x fix exists). Used only
  by virtualenv and python-discovery, both pre-commit tooling. Both
  accept 4.x (virtualenv: >=3.24.2,<5; python-discovery: >=3.16.1),
  and 4.2.1 needs Python 3.11, SENTINEL's floor.
- virtualenv 21.7.13 -> 21.14.10 (eleven CVEs; 21.14.9 still had one
  more, CVE-2026-113713, fixed in 21.14.10). Its requirements raise
  packaging to 26.3 and distlib to 0.4.3, the smallest versions that
  satisfy them.

Smallest fixed versions throughout, as CONTRIBUTING asks. pip-audit
2.10.1, run exactly as CI runs it, now finds no known vulnerabilities;
scripts/check_versions_lock.py reports 0 conflicts; pip check finds no
broken requirements; the full suite passes on the new pins.

Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
@Harshith029
Harshith029 merged commit fc7bb74 into main Oct 24, 2026
7 checks passed
@Harshith029 Harshith029 mentioned this pull request Oct 24, 2026
1 task done
@Harshith029
Harshith029 deleted the deps-audit-2026-10 branch October 24, 2026 15:41
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant