@@ -624,7 +624,7 @@ protected void handleHandshakeMessage(short type, HandshakeMessageInput buf)
624624 }
625625 else
626626 {
627- keyExchange .processClientCredentials (clientAuthCredentials );
627+ keyExchange .processClientCredentials (clientAuthCredentials );
628628 }
629629
630630 Vector clientSupplementalData = tlsClient .getClientSupplementalData ();
@@ -637,7 +637,7 @@ protected void handleHandshakeMessage(short type, HandshakeMessageInput buf)
637637 if (certificateRequest != null )
638638 {
639639 sendCertificateMessage (clientAuthCertificate , null );
640- this .connection_state = CS_CLIENT_CERTIFICATE ;
640+ this .connection_state = CS_CLIENT_CERTIFICATE ;
641641 }
642642
643643 sendClientKeyExchange ();
@@ -879,7 +879,7 @@ protected void process13HelloRetryRequest(ServerHello helloRetryRequest)
879879 continue ;
880880 }
881881
882- if (null == TlsUtils .getExtensionData (clientExtensions , extType ))
882+ if (! TlsUtils .hasExtension (clientExtensions , extType ))
883883 {
884884 throw new TlsFatalAlert (AlertDescription .unsupported_extension ,
885885 "Unrequested extension in HelloRetryRequest: " + ExtensionType .getText (extensionType ));
@@ -1252,7 +1252,7 @@ protected void processServerHello(ServerHello serverHello)
12521252 /*
12531253 * RFC 3546 2.2 Note that the extended server hello message is only sent in response to an
12541254 * extended client hello message.
1255- *
1255+ *
12561256 * However, see RFC 5746 exception below. We always include the SCSV, so an Extended Server
12571257 * Hello is always allowed.
12581258 */
@@ -1283,7 +1283,7 @@ protected void processServerHello(ServerHello serverHello)
12831283 * associated ClientHello, it MUST abort the handshake with an unsupported_extension
12841284 * fatal alert.
12851285 */
1286- if (null == TlsUtils .getExtensionData (clientHelloExtensions , extType ))
1286+ if (! TlsUtils .hasExtension (clientHelloExtensions , extType ))
12871287 {
12881288 throw new TlsFatalAlert (AlertDescription .unsupported_extension ,
12891289 "Unrequested extension in ServerHello: " + ExtensionType .getText (extType .intValue ()));
@@ -1508,7 +1508,7 @@ protected void receive13CertificateRequest(ByteArrayInputStream buf, boolean pos
15081508 throw new TlsFatalAlert (AlertDescription .internal_error );
15091509 }
15101510
1511- /*
1511+ /*
15121512 * RFC 8446 4.3.2. A server which is authenticating with a certificate MAY optionally
15131513 * request a certificate from the client.
15141514 */
@@ -1554,7 +1554,7 @@ protected void receive13EncryptedExtensions(ByteArrayInputStream buf)
15541554 {
15551555 Integer extType = (Integer )e .nextElement ();
15561556
1557- if (null == TlsUtils .getExtensionData (clientExtensions , extType ))
1557+ if (! TlsUtils .hasExtension (clientExtensions , extType ))
15581558 {
15591559 throw new TlsFatalAlert (AlertDescription .unsupported_extension ,
15601560 "Unrequested extension in EncryptedExtensions: " + ExtensionType .getText (extType .intValue ()));
@@ -1918,7 +1918,7 @@ protected void sendClientHello()
19181918 this .clientBinders = TlsUtils .addPreSharedKeyToClientHello (tlsClientContext , tlsClient , clientExtensions ,
19191919 offeredCipherSuites );
19201920
1921- // TODO[tls13-psk] Perhaps don't add key_share if external PSK(s) offered and 'psk_dhe_ke' not offered
1921+ // TODO[tls13-psk] Perhaps don't add key_share if external PSK(s) offered and 'psk_dhe_ke' not offered
19221922 this .clientAgreements = TlsUtils .addKeyShareToClientHello (tlsClientContext , tlsClient , clientExtensions );
19231923
19241924 if (shouldUseEMS && TlsUtils .isExtendedMasterSecretOptional (supportedVersions ))
@@ -1967,7 +1967,7 @@ else if (offeringTLSv12Minus)
19671967 * TLS_EMPTY_RENEGOTIATION_INFO_SCSV signaling cipher suite value in the ClientHello.
19681968 * Including both is NOT RECOMMENDED.
19691969 */
1970- boolean noRenegExt = ( null == TlsUtils .getExtensionData (clientExtensions , EXT_RenegotiationInfo ) );
1970+ boolean noRenegExt = ! TlsUtils .hasExtension (clientExtensions , EXT_RenegotiationInfo );
19711971 boolean noRenegSCSV = !Arrays .contains (offeredCipherSuites , CipherSuite .TLS_EMPTY_RENEGOTIATION_INFO_SCSV );
19721972
19731973 if (noRenegExt && noRenegSCSV )
0 commit comments