Skip to content

Commit 943165e

Browse files
Merge pull request #246 from brownjuly2003-code/dependabot/pip/numpy-gte-2-and-lt-2.5
chore(deps): update numpy requirement from <2.4,>=2 to >=2,<2.5
2 parents fb3e0d0 + f06feed commit 943165e

2 files changed

Lines changed: 87 additions & 82 deletions

File tree

‎pyproject.toml‎

Lines changed: 11 additions & 4 deletions
Original file line numberDiff line numberDiff line change
@@ -102,10 +102,17 @@ dev = [
102102
"jsonschema>=4,<5",
103103
"mkdocs>=1.6,<2",
104104
"mkdocs-material>=9.6,<10",
105-
# NumPy 2.4+ bundles PEP 695 syntax in its stubs; mypy targeting the
106-
# supported Python 3.11 floor cannot parse those stubs. This is a dev/type
107-
# checking constraint, not an application runtime dependency.
108-
"numpy>=2,<2.4",
105+
# NumPy 2.5.0 requires Python >=3.12; 3.11 is a supported floor here, so
106+
# the ceiling is what keeps the lock resolvable across 3.11-3.13 rather
107+
# than a preference. (The ceiling was <2.4 from 2026-07-23, recorded as
108+
# "NumPy 2.4+ bundles PEP 695 syntax in its stubs" -- the released 2.4.0
109+
# and 2.4.6 wheels ship 264 stub files with no PEP 695 syntax in any of
110+
# them, so that reason does not hold for the 2.4 line. The mypy half is
111+
# still true and still worth watching: mypy 2.2.0 at --python-version 3.11
112+
# rejects a `type` statement outright, so a future stub release that uses
113+
# one turns lint red rather than degrading.) This is a dev/type-checking
114+
# constraint, not an application runtime dependency.
115+
"numpy>=2,<2.5",
109116
"pandas>=2.2,<4",
110117
"pytest>=8.3,<10",
111118
"pytest-asyncio>=0.24,<2",

0 commit comments

Comments
 (0)