Skip to content
#

json-schema-validator

Here are 129 public repositories matching this topic...

vacuum

vacuum is the worlds fastest and most versatile OpenAPI, Arazzo, AsyncAPI & JSON Schema linter, docs generator and toolkit. It tears through API specs at light speed. 100% compatible with Spectral rulesets, and OpenAPI 3.0, 3.1 and 3.2

  • Updated Oct 18, 2026
  • Go

Framework for representing, validating, querying, and manipulating generic JSON values in Swift 6. Supported are standards such as JSON Text Sequences (RFC 7464), JSON Pointer (RFC 6901), JSON Path (RFC 9535), JSON Patch (RFC 6902), JSON Merge Patch (RFC 7396), and JSON Schema.

  • Updated Oct 13, 2026
  • Swift

The ultra high-performance C++ JSON Schema validator, providing validation even down to the nano-second range (depends on schemas and hardware) along with perfect compliance scores. Supports Draft 4, Draft 6, Draft 7, 2019-09, 2020-12, and OpenAPI 3.0+. For both servers and embedded devices

  • Updated Oct 16, 2026
  • C++

High-performance .NET JSON Schema validator implementation based on System.Text.Json. Supports Draft 7, 2019-09, and 2020-12; includes fluent validation and schema creation from .NET types.

  • Updated Oct 16, 2026
  • C#

Add this topic to your repo

To associate your repository with the json-schema-validator topic, visit your repo's landing page and select "manage topics."

Learn more